Ionic installieren auf Mac OS X

Anbei eine Beschreibung wie man auf dem Mac die neue beta-Version von ionic 2 installiert

1.) Node installieren

2.) node ggf aktualiseren
sudo npm install -g npm@3

3.) Minimatch musste Manuel aktualisiert werden:
sudo npm install -g minimatch

4.) Angular v2 installieren
sudo npm install -g angular2

5.) Cordova installieren
(falls nicht nicht vorhanden/installiert)
sudo npm install -g cordova

6.) wie folgt ionic 2 beta installieren: http://ionicframework.com/docs/v2/getting-started/installation/ oder einfach folgendes ins Terminal eintragen:
sudo npm install -g ionic@beta

7.) Stand 10.8.: Update the ionic 2 beta:
sudo npm install --save ionic-angular @angular/{common,compiler,core,http,forms,platform-browser,platform-browser-dynamic} rxjs@5.0.0-beta.6 zone.js@0.6.12

8.) ich bekam dennoch Fehler:
npm WARN ionic-angular@2.0.0-beta.11 requires a peer of @angular/common@2.0.0-rc.4 but none was installed.
npm WARN ionic-angular@2.0.0-beta.11 requires a peer of @angular/compiler@2.0.0-rc.4 but none was installed.
npm WARN ionic-angular@2.0.0-beta.11 requires a peer of @angular/core@2.0.0-rc.4 but none was installed.
npm WARN ionic-angular@2.0.0-beta.11 requires a peer of @angular/forms@0.2.0 but none was installed.
npm WARN ionic-angular@2.0.0-beta.11 requires a peer of @angular/http@2.0.0-rc.4 but none was installed.
npm WARN ionic-angular@2.0.0-beta.11 requires a peer of @angular/platform-browser@2.0.0-rc.4 but none was installed.
npm WARN ionic-angular@2.0.0-beta.11 requires a peer of @angular/platform-browser-dynamic@2.0.0-rc.4 but none was installed.

Ich habe verschiedene Pakete noch manuell installiert, danach habe ich allerdings wiederholt denselben Fehler erhalten, ignorierte ihn aber (nach einem Hinweis hier).

9.) Ersten Test machen
Einfach der Anleitung hier folgenls

Und dann…. Follow this 🙂